Server issues
Incident Report for FA Forever
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 31, 2018 - 19:44 UTC
Investigating
We are currently investigating
Posted 3 months ago. Jul 31, 2018 - 19:41 UTC
This incident affected: Web Site, Replay Server, Updates Server, Forums, Wiki, API, IRC Server, Mumble Server, Mod vault, and Map vault.