Server Upgrade
Incident Report for FA Forever
Resolved
Server upgrade is finished and there should be no further service degradations.
Posted over 1 year ago. Aug 29, 2017 - 03:28 UTC
Identified
On Monday, August 28 2017, scheduled server upgrade will take place. Exact start and end are unknown.

During upgrade work, the FAF lobby server may stop being accessible at any time.

Check www.faforever.com/news for updates.
Posted over 1 year ago. Aug 28, 2017 - 14:34 UTC