Outgoing emails (Signup, password recovery) down
Incident Report for FA Forever
Resolved
Outbound emails are working again. Sorry for the inconvenience.
Posted almost 2 years ago. May 04, 2016 - 15:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted almost 2 years ago. Apr 30, 2016 - 10:06 UTC