Main website down
Incident Report for FA Forever
Resolved
Issue solved.
Posted over 1 year ago. Jul 18, 2016 - 16:52 UTC
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Jul 18, 2016 - 16:46 UTC